Please wait...
Please wait...

KB 1174

The Hasselbad V Series Camera will not activate the camera back

Last updated: 11-01-2021

Problem

When the release button is pushed the camera back is not responding. No LED's are flashing and no capture is made.

Solution

Summary

This can be caused by defective cable, lens or Hasselblad Release Arm (PIN)



In-Depth

1.) Please make sure that the digital back is turned on and/or connected to the computer system and, if tethered, that Capture One indicates that the back is ready for capture.

2.) Check the small sync cable that runs from the lens to the digital back is fully connected on both ends. This small sync cable is vital to the Digital Backs operation. It's a good idea to always have a spare on hand these are available from your Phase One dealer.

3.) Check the condition of the shutter. All shutters require periodic maintenence to insure the sync contacts work properly. Change lenses to check one lens against another. 

4.) Check the condition of the release arm (PIN) on the Hasseblad body. On the lower right side of the back of the Hasselblad body you will see a small PIN that extends from the body when the shutter release button is activated. It is important the this small PIN extends from the Hasselblad body at least 2.8-2.9 mm. 




It is also important that the PIN extends with a certain strength as a soft or slow extension of the PIN may cause inactivation of the camera back. Please contact Hasselblad service if you suspect any problems with the PIN. 

The inside portion of the PIN must be a shiny silver so that the optical sensor inside the back can see it. You can use an emory board or nylon cleaning pad to scape away any tarnish or paint (as displayed above). Alternatively you can use a silver paint pen to touch up the inside of the PIN.


Related Articles

KB1159: Black Previews / Black Captures
KB1369: 2-shot mode or green LEDs flashing on Hasselblad V series